OpenSSL‘ASN1_item_ex_d2i’函数安全漏洞 CVE-2015-0287 CNNVD-201503-399

5.0 AV AC AU C I A
发布: 2015-03-19
修订: 2017-11-15

OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL的crypto/asn1/tasn_dec.c文件中的‘ASN1_item_ex_d2i’函数存在安全漏洞,该漏洞源于程序没有重新初始化CHOICE和ADB数据类型。攻击者可借助特制的应用程序利用该漏洞造成拒绝服务(无效的写入操作和内存损坏)。以下版本受到影响:OpenSSL 0.9.8zf之前版本,1.0.0r之前1.0.0版本,1.0.1m之前1.0.1版本,1.0.2a之前1.0.2版本。

0%
暂无可用Exp或PoC
当前有33条受影响产品信息