OpenSSL 拒绝服务漏洞 CVE-2015-3196 CNNVD-201512-076

4.3 AV AC AU C I A
发布: 2015-12-06
修订: 2019-06-13

OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL的ssl/s3_clnt.c文件中存在安全漏洞,该漏洞源于程序在multi-threaded客户端使用时,向错误的数据结构体写入PSK身份标记。远程攻击者可借助特制的ServerKeyExchange标记利用该漏洞造成拒绝服务(竞争条件和双重释放)。以下版本受到影响:OpenSSL 1.0.0t之前1.0.0版本,1.0.1p之前1.0.1版本,1.0.2d之前1.0.2版本。

0%
暂无可用Exp或PoC
当前有65条受影响产品信息