OpenSSL‘rsa_item_verify’函数拒绝服务漏洞 CVE-2015-0208 CNNVD-201503-395

4.3 AV AC AU C I A
发布: 2015-03-19
修订: 2018-11-29

OpenSSL是OpenSSL团队开发的一个开源的能够实现安全套接层(SSL v2/v3)和安全传输层(TLS v1)协议的通用加密库,它支持多种加密算法,包括对称密码、哈希算法、安全散列算法等。 OpenSSL 1.0.2a之前1.0.2版本的crypto/rsa/rsa_ameth.c文件中的‘rsa_item_verify’函数的ASN.1 signature-verification实现过程中存在安全漏洞,该漏洞源于使用certificate-verification功能的端点没有充分过滤‘RSA PSS’参数。远程攻击者可利用该漏洞造成拒绝服务(空指针逆向引用和应用程序崩溃)。

0%
当前有1条漏洞利用/PoC
当前有4条受影响产品信息