Linux kernel 和 Xen 代码问题漏洞 CVE-2020-29569

7.2 AV AC AU C I A
发布: 2020-12-15
修订: 2020-12-18

Linux kernel是美国Linux基金会的开源操作系统Linux所使用的内核。Xen是英国Cambridge大学的一款开源的虚拟机监视器产品。该产品能够使不同和不兼容的操作系统运行在同一台计算机上,并支持在运行时进行迁移,保证正常运行并且避免宕机。 Linux kernel through 5.10.1 与 Xen 4.14.x 一起使用时存在安全漏洞,该漏洞源于Linux内核PV块后端期望内核线程处理程序在停止时将ring->xenblkd重置为NULL。但是,如果前端在连接和断开状态之间快速切换,处理程序可能没有时间运行。因此,块后端可能会在释放指针后重用指针。行为不端的客户机可以通过持续连接、断开块前端的连接来触发dom0崩溃。不能排除特权升级和信息泄露的可能性。

0%
暂无可用Exp或PoC
当前有3条受影响产品信息