PHP‘ext/gd/gd.c’基于堆的缓冲区溢出漏洞 CVE-2016-7126 CNNVD-201609-074

7.5 AV AC AU C I A
发布: 2016-09-12
修订: 2020-10-13

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。 PHP 5.6.25之前版本和7.0.10之前的7.x版本中的ext/gd/gd.c文件中的‘imagetruecolortopalette’函数存在安全漏洞,该漏洞源于程序没有正确验证颜色数量。远程攻击者可借助第三参数中的‘large\'\'值利用该漏洞造成拒绝服务(select_colors配置错误和越边界写入)。

0%
当前有1条漏洞利用/PoC
当前有11条受影响产品信息