PHP SSL Certificate Validation 安全绕过漏洞 CVE-2013-4248 CNNVD-201308-244

4.3 AV AC AU C I A
发布: 2013-08-18
修订: 2016-11-28

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。 PHP中的OpenSSL模块中的openssl.c文件中的‘openssl_x509_parse’函数中存在安全漏洞,模块没有正确处理X.509证书的Subject Alternative Name字段中带有空字节的主机名。攻击者可通过中间人攻击利用该漏洞欺骗SSL服务器。成功的利用此漏洞需要获得由权威机构签署并且客户信任的证书。以下版本受到影响:PHP 5.4.17及之前的版本和5.5.0版本及5.5.2版本。

0%
当前有7条漏洞利用/PoC
当前有95条受影响产品信息