PHP XMLRPC扩展缓冲区溢出漏洞 CVE-2014-3668 CNNVD-201410-1339

5.0 AV AC AU C I A
发布: 2014-10-29
修订: 2016-10-18

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。XMLRPC是其中的一个用于实现XML-RPC协议的库。 PHP XMLRPC扩展中的libxmlrpc/xmlrpc.c脚本中mkgmtime实现过程中的‘date_from_ISO8601’函数中存在缓冲区溢出漏洞,该漏洞源于‘xmlrpc_set_type’函数没有充分过滤‘first’参数;‘xmlrpc_decode’函数没有充分过滤参数。远程攻击者可利用该漏洞造成拒绝服务(应用程序崩溃)。以下版本受到影响:PHP 5.4.33及之前版本,5.5.18之前5.5.x版本,5.6.2之前5.6.x版本。

0%
当前有7条漏洞利用/PoC
当前有70条受影响产品信息