PHP EXIF扩展缓冲区溢出漏洞 CVE-2014-3670 CNNVD-201410-1345

6.8 AV AC AU C I A
发布: 2014-10-29
修订: 2016-10-18

PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHP Group和开放源代码社区共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。EXIF(可交换图像文件的缩写)是其中的一个可记录图像的属性信息和拍摄数据的扩展。 PHP EXIF扩展中的exif.c脚本中‘exif_ifd_make_value’函数存在安全漏洞,该漏洞源于程序不正确地操作‘floating-point’数组。远程攻击者可借助带有TIFF缩略图数据的JPEG图片利用该漏洞造成拒绝服务(堆内存消耗和应用程序崩溃)或执行任意代码。以下版本受到影响:PHP 5.4.33及之前版本,5.5.18之前5.5.x版本,5.6.2之前5.6.x版本。

0%
当前有2条漏洞利用/PoC
当前有70条受影响产品信息